Функция СУММЕСЛИ в Excel


В данной статье речь пойдет о функции СУММЕСЛИ в Excel. Если вы столкнулись с задачей, в которой вам необходимо посчитать сумму при определенном условии, то функция СУММЕСЛИ – это то, что вам нужно. В начале мы разберем синтаксис функции СУММЕСЛИ в Excel и ее применение, а затем закрепим новые знания на практике при помощи ряда примеров формулы СУММЕСЛИ в следующей статье.

Функция СУММЕСЛИ используется для суммирования ячеек на основе определенного условия или критерия. Обратите внимание, что функция СУММЕСЛИ идентично работает во всех версиях с Excel 2003 до Excel 2016.

Синтаксис функции СУММЕСЛИ выглядит следующим образом:

=СУММЕСЛИ(диапазон; критерий; [диапазон_суммирования])

Как вы видите, у функции СУММЕСЛИ есть 3 аргумента: первые два обязательные аргументы, а третий – необязательный.

  1. диапазон – диапазон ячеек, который будет оцениваться по вашим критериям, например A1:A10.
  2. критерий – условие, которое должно быть выполнено. Критерий может быть представлен в виде числа, текста, даты, логического выражения, ссылки на ячейку или другую функцию Excel. Например, вы можете ввести такие критерии, как «5», «яблоки», «25.10.2017», «<7», «A1» и т. д.

Обратите внимание, что любые текстовые критерии, или критерии, содержащие математические символы, в функции СУММЕСЛИ должны быть заключены в двойные кавычки ("). Для числовых критериев двойные кавычки не требуются.

  1. диапазон_суммирования - ячейки для суммирования, если условие выполнено. Этот аргумент является необязательным, и вам нужно использовать его только в том случае, если вы хотите суммировать ячейки, отличные от определенных в аргументе диапазона. Если аргумент диапазон_суммирования пропущен формуле СУММЕСЛИ, Excel будет суммировать те же ячейки, к которым применяются критерии (т.е. указанные в диапазоне).

Чтобы лучше иллюстрировать синтаксис функции СУММЕСЛИ в Excel, давайте рассмотрим следующий пример. Предположим, у вас есть список продуктов в столбце A и соответствующие количества в столбце C. Вы хотите знать общую сумму количества, определенного продукта, например, бананов.

1-funktciia-summesli-v-excel

Функция СУММЕСЛИ в Excel с примерами– Данные, которые должны быть суммированы по условию

Теперь давайте определим аргументы нашей формулы СУММЕСЛИ:

  • диапазон - A2:A8
  • критерии - "Бананы"
  • диапазон_суммирования - C2:C8

Объединяя это, мы получаем формулу:

=СУММЕСЛИ(A2:A8; "Бананы"; C2:C8)

2-funktciia-summesli-v-excel

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ

Этот пример функции СУММЕСЛИ демонстрирует простейшее использование функции с текстовым критерием. Вместо текста вы можете указать число, дату или ссылку на ячейку в критерии. Например, вы можете переписать вышеприведенную формулу так, чтобы она ссылалась на ячейку, содержащую имя продукта, для которого нужно суммировать количество:

=СУММЕСЛИ(A2:A8; F1; C2:C8)

Примечание. Параметр диапазон_суммирования фактически указывает только верхнюю левую ячейку диапазона, который будет суммироваться. Оставшаяся область определяется размерами аргумента диапазона. 

На практике это означает, что аргумент функции СУММЕСЛИ диапазон_суммирования необязательно должен иметь тот же размер, что и аргумент диапазона, то есть он может иметь разное количество строк и столбцов. Однако первая ячейка (т.е. верхняя левая ячейка) диапазона сумм всегда должна быть правой. Например, в приведенной выше формуле СУММЕСЛИ вы можете поставить C2 или C2:C4 или даже C2:C100 в качестве аргумента диапазон_суммирования, и результат все равно будет таким же. Однако наилучшей практикой является задание одинакового размера диапазона и диапазон_суммирования.

Надеюсь, приведенный выше пример помог вам получить общее представление о том, как работает функция СУММЕСЛИ. В следующей статье мы рассмотрим множество примеров функции СУММЕСЛИ с разными условиями.


Категории: MS Excel  

Об этой статье

funktciia-summesli-v-excel-avatar
2018-01-19 09:34:09
701
user
MS Office; Office 2003; Office 2013; MS Excel; Excel 2003; Excel 2010; Excel 2013; Функции Excel; Office 2007; Office 2010; Office 2016; Excel 2016; Excel 2007;
В статье рассмотрен синтаксис функции СУММЕСЛИ в Excel и ее применение, а также пример функции СУММЕСЛИ.