Как посчитать сумму в столбце в Excel


В данной статье будет рассмотрено, как посчитать сумму в столбце в Excel, а также как посчитать сумму в столбце с неопределенным количеством строк, и как посчитать сумму в столбце за исключением заголовка или исключая несколько первых строк.

Как посчитать сумму в столбце с помощью функции СУММ

Чтобы посчитать сумму в столбце, вы можете использовать функцию Excel СУММ. Например, чтобы посчитать сумму в столбце B, например, в ячейках B2-B8, введите следующую формулу Excel СУММ:

=СУММ(В2:В8)

1-kak-poschitat-summu-v-stolbtce-v-excel

Как посчитать сумму в столбце в Excel – Посчитать сумму в столбце

Существует второй способ, как в Excel посчитать сумму столбца автоматически. Для этого выберите последнюю пустую ячейку в столбце, в котором вы хотите посчитать сумму. На вкладке «ГЛАВНАЯ» в группе «Редактирование», нажмите «Автосумма» и клавишу «Enter». После этого в ячейке будет автоматически введена формула «СУММ»:

2-kak-poschitat-summu-v-stolbtce-v-excel

Как посчитать сумму в столбце в Excel – В таблице посчитать сумму столбца с использованием Автосуммы

Как посчитать сумму в столбце с неопределенным количеством строк

Если вам необходимо посчитать сумму в столбце, который имеет переменное количество строк (т. е. новые ячейки могут быть добавлены, а существующие могут быть удалены в любое время), вы можете посчитать сумму всего столбца, указав ссылку на столбец, но не указав нижнюю или верхнюю границу, например:

=СУММ(B:B)

Обратите внимание! Ни в коем случае не следует размещать формулу «Сумма столбца» в столбец, в котором вы хотите посчитать сумму, потому что это создаст циклическую ссылку на ячейку (т. е. бесконечное рекурсивное суммирование), и ваша формула СУММ вернет 0.

3-kak-poschitat-summu-v-stolbtce-v-excel

Как посчитать сумму в столбце в Excel – Посчитать сумму в столбце, используя ссылку на столбец

Как посчитать сумму в столбце за исключением заголовка или исключая несколько первых строк

Обычно ссылки на столбцы используются в формуле СУММ для того, чтобы посчитать сумму в столбце, игнорируя заголовок, как показано на приведенном выше изображении. Но в некоторых случаях заголовок столбца может содержать какое-то числовое значение. Или, например, вы хотите исключить первые несколько строк с числами, которые не имеют отношения к данным.

К сожалению, Microsoft Excel не принимает смешанную формулу СУММ с явной нижней границей, но без верхней границы, например, такой как =СУММ(B2: B). Если вам необходимо посчитать сумму в столбце, исключив первые несколько строк, вы можете использовать одно из следующих нескольких решений.

  1. Посчитайте сумму столбца, а затем вычтите ячейки, которые вы не хотите включать в общую сумму (ячейки B1-B3 в данном примере):

=СУММ(B:B) - СУММ(B1:B3)

4-kak-poschitat-summu-v-stolbtce-v-excel

Как посчитать сумму в столбце в Excel – Посчитать сумму в столбце за исключением нескольких первых строк
  1. Помня о лимитах размера листа, вы можете указать верхнюю границу формулы СУММ на основе максимального количества строк в вашей версии Excel.

Например, чтобы посчитать сумму в столбце B без заголовка (т. е. исключая ячейку B1), вы можете использовать следующие формулы:

В Excel 2007, Excel 2010, Excel 2013 и Excel 2016:

=СУММ(В2:B1048576)

В Excel 2003:

=СУММ(В2:B655366)

В этой статье мы рассмотрели разные способы, как посчитать сумму в столбце в Excel, и теперь вы можете выбрать любой из них в зависимости от ситуации.


Категории: MS Excel  

Об этой статье

kak-poschitat-summu-v-stolbtce-v-excel-avatar
2018-01-18 09:29:14
1304
user
Office 2003; MS Office; Office 2013; MS Excel; Excel 2003; Excel 2010; Excel 2013; Функции Excel; Office 2007; Office 2010; Excel 2016; Подсчет суммы; Office 2016; Автосумма; Excel 2007;
В статье рассмотрены различные способы, как посчитать сумму в столбце в Excel.