Как посчитать сумму в строке в Excel


В данной статье мы рассмотрим, как посчитать сумму в строке в Excel с помощью функции СУММ, а также, как посчитать сумму в строке с неопределенным количеством столбцов.

Как посчитать сумму в строке с помощью функции СУММ

Самым распространенным способом, как посчитать сумму в строке в Excel, является способ с использованием функции СУММ. Например, чтобы посчитать сумму ячеек в строке в диапазоне B2-D2, используйте следующую формулу:

=СУММ(B2:D2)

1-kak-poschitat-summu-v-stroke-v-excel

Как посчитать сумму в строке в Excel – Посчитать сумму в строке в Excel

Вставить функцию СУММ можно с помощью кнопки «Автосумма», которая находится на вкладке «ГЛАВНАЯ» в группе «Редактирование». Для этого достаточно выбрать ячейку, где нужно автоматически посчитать сумму в строке и нажать на «Автосумму» и на клавишу «Enter».

Как посчитать сумму нескольких строк в Excel

Чтобы посчитать сумму в каждой строке, просто перетащите формулу СУММ. Ключевым моментом является использование относительных (без $) или смешанных ссылок на ячейки (где знак $ фиксирует только столбцы). Об относительных, абсолютных и смешанных ссылках описано в этой статье.

Например:

=СУММ($В2:$D2)

Протяните маркер заполнения вниз, чтобы скопировать формулу для других строк.

2-kak-poschitat-summu-v-stroke-v-excel

Как посчитать сумму в строке в Excel – Копирование формулы вниз для суммирования значений для каждой строки

Чтобы посчитать сумму значений в диапазоне, содержащем несколько строк, просто укажите желаемый диапазон в формуле СУММ. Например:

=СУММ(B2:D6) – посчитает сумму в строках 2-6.

=СУММ(B2:D3; B5:D6) – посчитает сумму в строках 2, 3, 5 и 6.

Как посчитать сумму строки

Чтобы посчитать сумму всей строки с неопределенным количеством столбцов, поставьте ссылку на всю строку в формуле СУММ, например:

=СУММ(2:2)

Помните, что вы не должны вводить формулу суммы строки в любой ячейке той же строки, чтобы избежать создания циклической ссылки, так как это приведет к неправильному вычислению:

3-kak-poschitat-summu-v-stroke-v-excel

Как посчитать сумму в строке в Excel – Посчитать сумму всей строки

Чтобы посчитать сумму в строке в Excel, исключая определенный столбец (столбцы), следует посчитать сумму во всей строке, а затем вычесть ненужные столбцы. Например, чтобы посчитать сумму в строке 2, за исключением первых двух столбцов, используйте следующую формулу:

=СУММ(2:2) - СУММ(А2:В2)

В этой статье мы рассмотрели разные способы, как посчитать сумму в строке в Excel, и теперь вы можете быстро посчитать сумму нескольких строк, или посчитать сумму строки с неопределенным количеством столбцов.


Категории: MS Excel  

Об этой статье

kak-poschitat-summu-v-stroke-v-excel-avatar
2018-01-18 10:18:58
1605
user
MS Office; Office 2003; Office 2013; MS Excel; Excel 2003; Excel 2010; Excel 2013; Функции Excel; Office 2007; Office 2010; Office 2016; Excel 2016; Подсчет суммы; Автосумма; Excel 2007;
В статье рассмотрены разные способы, как посчитать сумму в строке в Excel, с помощью которых можно быстро посчитать сумму нескольких строк, или посчитать сумму строки с неопределенным количеством столбцов.